DragonFly On-Line Manual Pages
AE(4) DragonFly Kernel Interfaces Manual AE(4)
ae -- Attansic/Atheros L2 FastEthernet controller driver
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The ae device driver provides support for Attansic/Atheros L2 PCIe
The controller supports hardware Ethernet checksum processing, hardware
VLAN tag stripping/insertion and an interrupt moderation mechanism.
Attansic L2 also features a 64-bit multicast hash filter.
The ae driver supports the following media types:
autoselect Enable autoselection of the media type and options. The
user can manually override the autoselected mode by adding
media options to rc.conf(5).
10baseT/UTP Select 10Mbps operation.
100baseTX Set 100Mbps (FastEthernet) operation.
The ae driver provides support for the following media options:
full-duplex Force full duplex operation.
half-duplex Force half duplex operation.
For more information on configuring this device, see ifconfig(8).
The ae driver supports Attansic/Atheros L2 PCIe FastEthernet controllers,
and is known to support the following hardware:
* ASUS EeePC 701
* ASUS EeePC 900
Other hardware may or may not work with this driver.
The ae driver collects a number of useful MAC counter during the work.
The statistics is available via the dev.ae.%d.stats sysctl(8) tree, where
%d corresponds to the controller number.
ae%d: watchdog timeout. The device has stopped responding to the net-
work, or there is a problem with the network connection (cable).
ae%d: reset timeout. The card reset operation has been timed out.
ae%d: Generating random ethernet address. No valid ethernet address was
found neither in the controller registers not in NVRAM. Random locally
administered address with ASUS OUI identifier will be used instead.
arp(4), ifmedia(4), miibus(4), netintro(4), ng_ether(4), vlan(4),
The ae driver and this manual page were written by Stanislav Sedov
<stas@FreeBSD.org>. It first appeared in FreeBSD 7.1.
The Attansic L2 FastEthernet contoller supports DMA but do not use a
descriptor based transfer mechanism via scatter-gather DMA. Thus the
data should be copied to/from the controller memory on each trans-
mit/receive. Furthermore, a lot of data alignment restrictions apply.
This may introduce a high CPU load on systems with heavy network activ-
ity. Luckily enough this should not be a problem on modern hardware as
L2 does not support speeds faster than 100Mbps.
DragonFly 5.1 November 28, 2014 DragonFly 5.1