DragonFly On-Line Manual Pages
AN(4) DragonFly Kernel Interfaces Manual AN(4)
an -- Aironet Communications 4500/4800 wireless network adapter driver
The an driver provides support for Aironet Communications 4500 and 4800
wireless network adapters. This includes the PCI and PCMCIA varieties.
The 4500 series adapters operate at 1 and 2Mbps while the 4800 series can
operate at 1, 2, 5.5 and 11Mbps. The PCI and PCMCIA devices are all
based on the same core PCMCIA modules and all have the same programming
interface, however unlike the Lucent WaveLAN/IEEE cards, the PCI cards
appear to the host as normal PCI devices and do not require any PCCARD
support. The PCMCIA Aironet cards require kernel pccard driver support.
PCI cards require no switch settings of any kind and will be automati-
cally probed and attached.
All host/device interaction with the Aironet cards is via programmed I/O.
The Aironet devices support 802.11 and 802.3 frames, power management,
BSS (infrastructure) and IBSS (ad-hoc) operation modes. The an driver
encapsulates all IP and ARP traffic as 802.11 frames, however it can
receive either 802.11 or 802.3 frames. Transmit speed is selectable
between 1Mbps, 2Mbps, 5.5Mbps, 11Mbps or "auto" (the NIC automatically
chooses the best speed).
By default, the an driver configures the Aironet card for infrastructure
For more information on configuring this device, see ifconfig(8)
an%d: init failed The Aironet card failed to come ready after an ini-
tialization command was issued.
an%d: failed to allocate %d bytes on NIC The driver was unable to allo-
cate memory for transmit frames in the NIC's on-board RAM.
an%d: device timeout The Aironet card failed to generate an interrupt to
acknowledge a transmit command.
arp(4), ifmedia(4), netintro(4), ancontrol(8), ifconfig(8)
The an device driver first appeared in FreeBSD 4.0.
The an driver was written by Bill Paul <firstname.lastname@example.org>.
DragonFly 4.5 September 10, 1999 DragonFly 4.5
AN 0.93(6) AN 0.93(6)
an - Anagram generator
an [-w] [-c string] [-d dictionary] [-l number_words] [-m word_length]
[-u string] [-n number_anagrams] [--words] [--contain string] [--dict
dictionary] [--length number_words] [--minimum word_length] [--used
string] [--number number_anagrams] [--help] [--version] PHRASE
an finds all anagrams which can be made from the letters in PHRASE,
using words in the specified dictionary (default=/usr/dict/words).
Print words that PHRASE letters can make, then exit.
-c, --contain string
Only print anagrams which contain string
-d, --dict dictionary
Use dictionary file to find words which letters in PHRASE can
-m, --minimum word_length
Only uses words which are at least word_length long.
-u, --used string
Considers that letters in string have allready used when analyz-
ing letters in PHRASE
-l, --length number_words
Finds anagrams which have a maximum of number_words words in
them, very useful when number of anagrams output is large.
-n, --number number_anagrams
Specifies number_anagrams as the maximum number of anagrams to
--help Print a usage message on standard output then exit
Print version information on standard output then exit
an -c acid 'Richard Jones'
Finds anagrams for Richard Jones which contain the word acid
Richard Jones (email@example.com)
- Coding and algorithm design.
Julian Assange (firstname.lastname@example.org)
- Algorithm design.
Copyright (c) Free Software Foundation, 1996.
Copyright (c) Richard Jones 1995, 1996, All rights reserved.
Please report any bugs to email@example.com
Suggestions and contributions are also welcome.