DragonFly On-Line Manual Pages
ACPICONF(8) DragonFly System Manager's Manual ACPICONF(8)
acpiconf, apm -- control ACPI power management
acpiconf [-h] [-i batt] [-k ack] [-s type]
The acpiconf utility allows the user control of the ACPI power management
functions. The following command-line options are recognized:
-h Displays a summary of available options.
-i batt Get design information about the specified battery. A value of
0 means the first battery.
-k ack Ack or abort a pending suspend request using the argument pro-
vided. Most users should not use this option directly.
-s type Enters the specified sleep mode. Recognized types are 1 (only
the CPU clock is stopped), 2 (not implemented on most systems
but similar to S1), 3 (the CPU context is lost and memory con-
text is preserved), 4 (the CPU context is lost and memory con-
text is stored to disk) and 5 (soft off). Sleep states may also
be given as S1, S2, etc. The supported states depend on BIOS
implementation, including ACPI byte code (AML). If the
/etc/rc.suspend and /etc/rc.resume scripts are executable, they
will be run before and after entering the given sleep state.
apm is a shortcut for acpiconf -i 0.
acpi(4), acpibin(8), acpicall(8), acpidump(8), acpiexec(8), acpihelp(8),
acpinames(8), acpixtract(8), iasl(8)
The acpiconf utility appeared in FreeBSD 5.0.
The acpiconf utility was written by Mitsuru Iwasaki
<iwasaki@FreeBSD.org>. This manual page was written by Dag-Erling
DragonFly 5.1 June 20, 2015 DragonFly 5.1