DragonFly On-Line Manual Pages
CHROOT(8) DragonFly System Manager's Manual CHROOT(8)
chroot -- change root directory
chroot [-u user] [-g group] [-G group,group,...] newroot [command]
The chroot utility changes its current and root directories to the sup-
plied directory newroot and then exec's command, if supplied, or an
interactive copy of the user's login shell.
If the -u, -g or -G options are given, the user, group and group list of
the process are set to these values after the chroot(8) has taken place.
The following environment variable is referenced by chroot:
SHELL If set, the string specified by SHELL is interpreted as the name
of the shell to exec. If the variable SHELL is not set, /bin/sh
chdir(2), chroot(2), setgid(2), setgroups(2), setuid(2), getgrnam(3),
The chroot utility first appeared in 4.4BSD.
DragonFly 5.3 January 24, 2003 DragonFly 5.3
CHROOT(2) DragonFly System Calls Manual CHROOT(2)
chroot, chroot_kernel -- change root directory
Standard C Library (libc, -lc)
chroot(const char *dirname);
chroot_kernel(const char *dirname);
Dirname is the address of the pathname of a directory, terminated by an
ASCII NUL. Chroot() causes dirname to become the root directory, that
is, the starting point for path searches of pathnames beginning with `/'.
In order for a directory to become the root directory a process must have
execute (search) access for that directory.
It should be noted that chroot() has no effect on the process's current
This call is restricted to the super-user.
Depending on the setting of the kern.chroot_allow_open_directories sysctl
variable, open filedescriptors which reference directories will make the
chroot() fail as follows:
If kern.chroot_allow_open_directories is set to zero, chroot() will
always fail with EPERM if there are any directories open.
If kern.chroot_allow_open_directories is set to one (the default),
chroot() will fail with EPERM if there are any directories open and the
process is already subject to a chroot() call.
Any other value for kern.chroot_allow_open_directories will bypass the
check for open directories
Upon successful completion, a value of 0 is returned. Otherwise, a value
of -1 is returned and errno is set to indicate an error.
The chroot_kernel() system call adjusts the kernel's internal namecache
and root vnode references to dirname. If used in conjunction with
chroot() during early boot, it allows for changing the root mount to any
mount point available at that time.
Chroot() will fail and the root directory will be unchanged if:
[ENOTDIR] A component of the path name is not a directory.
[EPERM] The effective user ID is not the super-user, or one or
more filedescriptors are open directories.
[ENAMETOOLONG] A component of a pathname exceeded 255 characters, or
an entire path name exceeded 1023 characters.
[ENOENT] The named directory does not exist.
[EACCES] Search permission is denied for any component of the
[ELOOP] Too many symbolic links were encountered in translat-
ing the pathname.
[EFAULT] dirname points outside the process's allocated address
[EIO] An I/O error occurred while reading from or writing to
the file system.
The chroot() function call appeared in 4.2BSD.
DragonFly 5.3 August 1, 2010 DragonFly 5.3