DragonFly On-Line Manual Pages
CRYPTO(4) DragonFly Kernel Interfaces Manual CRYPTO(4)
crypto, cryptodev -- hardware crypto access driver
The crypto driver provides a device-independent framework to support
cryptographic operations in the kernel. The cryptodev driver provides
userland applications access to this support through the /dev/crypto
device. This node primarily operates in an ioctl(2) based model, permit-
ting a variety of applications to query device capabilities, submit
transactions, and get results.
If count given in the specification, and is greater than 0, a maximum of
one crypto device is created.
The following ioctl(2) calls apply only to the crypto devices:
CIOCGSESSION Setup a new crypto session for a new type of operation.
CIOCFSESSION Free a previously established session.
CIOCCRYPT Perform a crypto operation against a previously setup ses-
Depending on hardware being present, the following symmetric and asymmet-
ric cryptographic features are potentially available from /dev/crypto:
/dev/crypto crypto access device
aesni(4), hifn(4), ipsec(4), padlock(4), safe(4), ubsec(4), crypto(9)
The crypto driver first appeared in OpenBSD 3.0. The crypto driver was
imported to FreeBSD 5.0.
DragonFly 4.9 August 21, 2010 DragonFly 4.9