DragonFly On-Line Manual Pages
DM(4) DragonFly Kernel Interfaces Manual DM(4)
dm -- Device-mapper disk driver
The dm driver provides the capability of creating one or more virtual
disks based on the target mapping.
This document assumes that you're familiar with how to generate kernels,
how to properly configure disks and devices in a kernel configuration
file, and how to partition disks. This driver is used by the Linux
lvm2tools to create and manage lvm in DragonFly.
Currently, the linear, zero, error, crypt, and stripe targets are imple-
mented. In order to compile in support for dm, you must add a line simi-
lar to the following to your kernel configuration file:
device dm #device-mapper disk device
dm may create linear mapped devices, zero, and error block devices. Zero
and error block devices are used mostly for testing. Linear devices are
used to create virtual disks with linearly mapped virtual blocks to
blocks on real disk. dm Device-mapper devices are controlled through the
/dev/mapper/control device. For controlling this device ioctl(2) calls
are used. For the implementation of the communication channel, the
proplib(3) library is used. The protocol channel is defined as a proplib
dictionary with needed values. For more details, look at
sys/dev/disk/dm/netbsd-dm.h. Before any device can be used, every
device-mapper disk device must be initialized. For initialization one
line must be passed to the kernel driver in the form of a proplib dictio-
nary. Every device can have more than one table active. An example for
such a line is:
0 10240 linear /dev/da0s1a 384
dm The first parameter is the start sector for the table defined with
this line, the second is the length in sectors which is described with
this table. The third parameter is the target name. All other parts of
this line depend on the chosen target. dm For the linear target, there
are two additional parameters: The first parameter describes the disk
device to which the device-mapper disk is mapped. The second parameter
is the offset on this disk from the start of the disk/partition.
proplib(3), config(8), dmsetup(8), fsck(8), lvm(8), mount(8), newfs(8)
The device-mapper disk driver first appeared in NetBSD 6.0.
It was then brought into DragonFly 2.7 by Alex Hornung.
Adam Hamsik <haad@NetBSD.org> implemented the dm driver for NetBSD.
Brett Blymn <blymn@NetBSD.org>, Reinoud Zandijk <reinoud@NetBSD.org>, and
Bill Stouder-Studenmund <wrstuden@NetBSD.org> provided guidance and
answered questions about the NetBSD implementation.
This driver is still work-in-progress--there can be bugs.
DragonFly 5.3 July 28, 2010 DragonFly 5.3