DragonFly On-Line Manual Pages
DM_TARGET_DELAY(4) DragonFly Kernel Interfaces Manual DM_TARGET_DELAY(4)
dm_target_delay - Device-mapper delay target
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The dm_target_delay target for dm(4) provides I/O delay for read or both
read and write, and maps them to specified devices, compatible with Linux
dm-delay. "dmsetup create" takes the following list of parameters for
the dm_target_delay table.
<read_device> <read_offset> <read_delay> [<write_device>
Parameters for write delay are optional. If write parameters are not
specified, read parameters are used for write. In order to only delay
read, explicitly specify 0 delay for write.
Offsets are specified in 512 bytes sectors. Delays are specified in
The dm_target_delay dm(4) target first appeared in DragonFly 4.3.
Tomohiro Kusumi <firstname.lastname@example.org>
DragonFly 5.7-DEVELOPMENT October 11, 2015 DragonFly 5.7-DEVELOPMENT