DragonFly On-Line Manual Pages
FFSINFO(8) DragonFly System Manager's Manual FFSINFO(8)
ffsinfo -- dump all meta information of an existing ufs file system
ffsinfo [-L] [-g cylinder_group] [-i inode] [-l level] [-o outfile]
special | file
The ffsinfo utility extends the dumpfs(8) utility.
The output is appended to the file outfile. Also expect the output file
to be rather large. Up to 2 percent of the size of the specified file
system is not uncommon.
The following options are available:
-L Specifying this option skips the tests of the disklabel. This is
done automatically, if the specified filename to dump is a plain
This restricts the dump to information about this cylinder group
only. Here 0 means the first cylinder group and -1 the last one.
This restricts the dump to information about this particular
inode only. Here the minimum acceptable inode is 2. If this
option is omitted but a cylinder group is defined then only
inodes within that cylinder group are dumped.
The level of detail which will be dumped. This value defaults to
255 and is the ``bitwise or'' of the following table:
0x001 initial superblock
0x002 superblock copies in each cylinder group
0x004 cylinder group summary in initial cylinder group
0x008 cylinder group information
0x010 inode allocation bitmap
0x020 fragment allocation bitmap
0x040 cluster maps and summary
0x080 rotational layout tables
0x100 inode information
0x200 indirect block dump
This allows to change the output filename where the dump is writ-
ten to. By default output goes to stdout.
ffsinfo -l 1023 /dev/vinum/testvol
will dump /dev/vinum/testvol with all available information.
disklabel(8), dumpfs(8), fsck(8), growfs(8), newfs(8), tunefs(8),
The ffsinfo utility first appeared in FreeBSD 4.4.
Christoph Herrmann <chm@FreeBSD.org>
Thomas-Henning von Kamptz <tomsoft@FreeBSD.org>
The GROWFS team <growfs@Tomsoft.COM>
Dumping a mounted filesystem will work, but may produce data which is not
DragonFly 5.1 September 8, 2000 DragonFly 5.1