DragonFly On-Line Manual Pages
FSTYP(8) DragonFly System Manager's Manual FSTYP(8)
fstyp -- determine filesystem type
fstyp [-l] [-s] [-u] special
The fstyp utility is used to determine the filesystem type on a given
device. It can recognize ISO-9660, Ext2, FAT, NTFS, UFS, HAMMER, and
HAMMER2 filesystems. When the -u flag is specified, fstyp also recog-
nizes certain additional metadata formats that cannot be handled using
The filesystem name is printed to the standard output as, respectively:
Note that HAMMER filesystem consists of more than one volumes requires a
path in blkdevs format. See hammer(8) for blkdevs format. fstyp doesn't
recognize partially specified block devices as HAMMER filesystem volumes
unless -u flag is specified.
Because fstyp is built specifically to detect filesystem types, it dif-
fers from file(1) in several ways. The output is machine-parsable,
filesystem labels are supported, and does not try to recognize any file
format other than filesystems.
These options are available:
-l In addition to filesystem type, print filesystem label if available.
-s Ignore file type. By default, fstyp only works on regular files and
disk-like device nodes. Trying to read other file types might have
unexpected consequences or hang indefinitely.
-u Include filesystems and devices that cannot be mounted directly by
The fstyp utility exits 0 on success, and >0 if an error occurs or the
filesystem type is not recognized.
file(1), autofs(5), hammer(8), hammer2(8), mount(8)
The fstyp command appeared in FreeBSD 10.2. The fstyp command appeared
in DragonFly 4.5.
The fstyp utility was developed by Edward Tomasz Napierala
<trasz@FreeBSD.org> under sponsorship from the FreeBSD Foundation. ZFS
and GELI support was added by Allan Jude <allanjude@FreeBSD.org>.
The fstyp utility was ported to DragonFly by Tomohiro Kusumi
<email@example.com>. Donated to DragonFlyBSD by PeerCorps Trust
The fstyp utility on DragonFly currently doesn't support zfs(8) pool and
geli(8) providers supported on FreeBSD.
DragonFly 5.1 October 12, 2017 DragonFly 5.1