DragonFly On-Line Manual Pages
GROUP(5) DragonFly File Formats Manual GROUP(5)
group -- format of the group permissions file
The group file is the local source of group information. It can be used
in conjunction with the Hesiod domain `group', and the NIS maps
`group.byname' and `group.bygid', as controlled by nsswitch.conf(5).
The file group consists of newline separated ASCII records, one per
group, containing four colon `:' separated fields. These fields are as
group Name of the group.
passwd Group's encrypted password.
gid The group's decimal ID.
member Group members.
Lines whose first non-whitespace character is a pound-sign (#) are com-
ments, and are ignored. Blank lines that consist only of spaces, tabs or
newlines are also ignored.
The group field is the group name used for granting file access to users
who are members of the group. The gid field is the number associated
with the group name. They should both be unique across the system (and
often across a group of systems) since they control file access. The
passwd field is an optional encrypted password. This field is rarely
used and an asterisk is normally placed in it rather than leaving it
blank. The member field contains the names of users granted the privi-
leges of group. The member names are separated by commas without spaces
or newlines. A user is automatically in a group if that group was speci-
fied in their /etc/passwd entry and does not need to be added to that
group in the group file.
There are various limitations which are explained in the function where
they occur; see section SEE ALSO.
In older implementations, a group cannot have more than 200 members. The
maximum line length of /etc/group is 1024 characters. Longer lines will
be skipped. This limitation disappeared in FreeBSD 3.0. Older binaries
that are statically linked, depend on old shared libraries, or
non-DragonFly binaries in compatibility mode may still have this limit.
passwd(1), setgroups(2), crypt(3), getgrent(3), initgroups(3),
nsswitch.conf(5), passwd(5), chkgrp(8), pw(8), yp(8)
A group file format appeared in Version 6 AT&T UNIX. Support for com-
ments first appeared in FreeBSD 3.0.
The passwd(1) command does not change the group passwords.
DragonFly 4.7 September 29, 1994 DragonFly 4.7