DragonFly On-Line Manual Pages
HOSTAPD(8) DragonFly System Manager's Manual HOSTAPD(8)
hostapd -- authenticator for IEEE 802.11 networks
hostapd [-BdhKtv] [-P pidfile] config-file ...
The hostapd utility is an authenticator for IEEE 802.11 networks. It
provides full support for WPA/IEEE 802.11i and can also act as an IEEE
802.1X Authenticator with a suitable backend Authentication Server (typi-
cally FreeRADIUS). The hostapd utility implements the authentication
protocols that piggyback on top of the normal IEEE 802.11 protocol mecha-
nisms. To use hostapd as an authenticator, the underlying device must
support some basic functionality such as the ability to set security
information in the 802.11 management frames. Beware that not all devices
have this support.
The hostapd utility is designed to be a ``daemon'' program that runs in
the background and acts as the backend component controlling the wireless
connection. It supports separate frontend programs such as the text-
based frontend, hostapd_cli(8).
The following arguments must be specified on the command line:
Use the settings in the specified configuration file; the name of
the specified wireless interface is contained in this file. See
hostapd.conf(5) for a description of the configuration file syn-
Changes to the configuration file can be reloaded by sending a
SIGHUP to the hostapd processor or with the hostapd_cli(8) util-
ity, using ``hostapd_cli reconfigure''.
The options are as follows:
-d Enable debugging messages. If this option is supplied twice,
more verbose messages are displayed.
-h Show help text.
-t Include timestamps in debugging output.
-v Display version information on the terminal and exit.
-B Detach from the controlling terminal and run as a daemon process
in the background.
-K Include key information in debugging output.
Store PID in pidfile.
ath(4), iwi(4), ral(4), rum(4), run(4), wi(4), hostapd.conf(5),
The hostapd utility first appeared in FreeBSD 6.0.
The hostapd utility was written by Jouni Malinen <firstname.lastname@example.org>. This manual
page is derived from the README file included in the hostapd distribu-
DragonFly 4.3 October 26, 2007 DragonFly 4.3
HOSTAPD(8) hostapd HOSTAPD(8)
hostapd - IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
hostapd [-hdBKtv] [-P <PID file>] <configuration file(s)>
This manual page documents briefly the hostapd daemon.
hostapd is a user space daemon for access point and authentication
servers. It implements IEEE 802.11 access point management, IEEE
802.1X/WPA/WPA2/EAP Authenticators and RADIUS authentication server.
The current version supports Linux (Host AP, mac80211-based drivers)
and FreeBSD (net80211).
hostapd is designed to be a "daemon" program that runs in the back-
ground and acts as the backend component controlling authentication.
hostapd supports separate frontend programs and an example text-based
frontend, hostapd_cli, is included with hostapd.
A summary of options is included below. For a complete description,
run hostapd from the command line.
-h Show usage.
-d Show more debug messages.
-dd Show even more debug messages.
-B Run daemon in the background.
-P <PID file>
Path to PID file.
-K Include key data in debug messages.
-t Include timestamps in some debug messages.
-v Show hostapd version.
hostapd was written by Jouni Malinen <email@example.com>.
This manual page was written by Faidon Liambotis <firstname.lastname@example.org>, for
the Debian project (but may be used by others).
hostapd April 7, 2005 HOSTAPD(8)