DragonFly On-Line Manual Pages
LM(4) DragonFly Kernel Interfaces Manual LM(4)
lm -- NatSemi LM78/79/81 and Winbond Super I/O Hardware Monitor
device lm0 at isa? port 0x290
device lm1 at isa? port 0x280
device lm2 at isa? port 0x310
device wbsio0 at isa? port 0x2e
device wbsio1 at isa? port 0x4e
device lm#3 at wbsio?
The lm driver provides support for the National Semiconductor LM 78/79/81
and Winbond Super I/O hardware monitors, and registers compatible chips
under the HW_SENSORS sysctl(3) tree.
Chips supported by the lm driver include:
- National Semiconductor LM78 and LM78-J
- National Semiconductor LM79
- National Semiconductor LM81
- Winbond W83627HF, W83627THF, W83637HF and W83697HF
- Winbond W83627DHG and W83627EHF
- Winbond W83781D, W83782D and W83783S
- Winbond W83791D, W83791SD and W83792D
- ASUS AS99127F
systat(1), sysctl(3), isa(4), wbsio(4), sensorsd(8), sysctl(8)
The lm driver first appeared in NetBSD 1.5, was ported to OpenBSD 3.4 and
imported into DragonFly 1.11.
The lm driver was written by Bill Squier and ported to OpenBSD 3.4 by
Alexander Yurchenko <email@example.com>. The driver was largely rewrit-
ten for OpenBSD 3.9 by Mark Kettenis <firstname.lastname@example.org>. The driver
was then ported to FreeBSD by Constantine A. Murenin <cnst@FreeBSD.org>
as a part of a Google Summer of Code 2007 project.
Some vendors connect these chips to non-standard thermal diodes and
resistors. This will result in bogus sensor values.
Interrupt support is unimplemented.
There are currently no known pnpbios IDs assigned to LM chips.
This driver attaches to the Winbond W83791SD chip even though that chip
does not have any sensors.
DragonFly 5.1 March 8, 2010 DragonFly 5.1