DragonFly On-Line Manual Pages
MODEMS(5) DragonFly File Formats Manual MODEMS(5)
modems -- modem configuration data base
The modems known by tip(1) and their attributes are stored in an ASCII
file which is structured somewhat like the termcap(5) file. Each line in
the file provides a description for a single modem. Fields are separated
by a colon (``:''). Lines ending in a \ character with an immediately
following newline are continued on the next line.
The first entry is the name(s) of the modem. If there is more than one
name for a modem, the names are separated by vertical bars. After the
name of the modem comes the fields of the description. A field name fol-
lowed by an `=' sign indicates a string value follows. A field name fol-
lowed by a `#' sign indicates a following numeric value.
When tip(1) is invoked, an entry for a remote system is looked up in the
/etc/remote database. If the entry includes an "ACU" type capability
(abbreviated at), tip(1) looks up the specified modem in /etc/modems. If
a modem entry is found, the corresponding capabilities determine how
tip(1) programs the modem when connecting to and disconnecting from the
Capabilities are either strings (str), numbers (num), or boolean flags
(bool). A string capability is specified by capability=value; for exam-
ple, ``reset_command=ATZ\r''. A numeric capability is specified by
capability#value; for example, ``intercharacter_delay#50''. A boolean
capability is specified by simply listing the capability.
dial_command (str) AT command used to dial remote system (typi-
echo_off_command (str) AT command to turn off command echo.
escape_guard_time (num) The delay, expressed in milliseconds, used to
frame return-to-command escape sequences.
escape_sequence (str) The return-to-command escape sequence.
hangup_command (str) AT command used to hangup modem.
hw_flow_control (bool) Enable hardware (RTS/CTS) flow control
between computer and modem (DTE/DCE).
init_string (str) AT command used to initialize modem before
intercharacter_delay (num) Delay value, expressed in milliseconds,
between characters when sending commands to the
intercommand_delay (num) Minimum delay value, expressed in millisec-
onds, to impose between commands issued to the
lock_baud (bool) Use a fixed bit rate between the computer
and the modem (DTE / DCE). The bit rate is speci-
fied in /etc/remote.
reset_command (str) AT command to reset the modem.
reset_delay (num) The time, expressed in milliseconds, required
by the modem to complete a reset and return to a
/etc/modems The modems configuration database file resides in /etc.
The modems file format appeared in 4.4BSD.
DragonFly 5.3 March 24, 1995 DragonFly 5.3