DragonFly On-Line Manual Pages
MOUNT_DEVFS(8) DragonFly System Manager's Manual MOUNT_DEVFS(8)
mount_devfs -- mount a device file system
mount_devfs [-o options] node
The mount_devfs command attaches an instance of the device file system
(or devfs(5)) to the global file system namespace. This command is auto-
matically executed for /dev at boot time.
The options are as follows:
-o Specify mount options, which are a comma delimited set of options
(see mount(8)). Supported mount options are:
jail Mount devfs(5) for a jail. Only rules between jail yes
and jail no are applied.
When mounting, apply the rules from the specified
rule_file, which can be either an absolute path or one
relative to /etc/devfs/.
Mounting an already mounted node clears and resets all rules that are in
effect for it and (if a ruleset option is present) applies the rules from
rule_file. It is equal to devfsctl -cr followed by an optional devfsctl
Mount a devfs(5), marked as jail, with a ruleset file named default.rules
mount_devfs -o jail,ruleset=default.rules /var/jail/dev
A corresponding fstab(5) entry is:
devfs /var/jail/dev devfs jail,ruleset=default.rules
mount(2), unmount(2), devfs(5), fstab(5), devfsctl(8), mount(8)
The mount_devfs utility first appeared in DragonFly 2.3.
DragonFly 5.3 August 17, 2009 DragonFly 5.3