DragonFly On-Line Manual Pages
MOUNT_HAMMER(8) DragonFly System Manager's Manual MOUNT_HAMMER(8)
mount_hammer -- mount a HAMMER file system
mount_hammer [-o options] [-T transaction-id] special ... node
mount_hammer [-o options] [-T transaction-id] special[:special]* node
mount_hammer -u [-o options] node
The mount_hammer utility mounts a HAMMER file system backed by special
file(s) at mount point node.
The options are as follows:
Options are specified with a -o flag followed by a comma sepa-
rated string of options. See the mount(8) man page for possible
options and their meanings. The following HAMMER specific
options are also available:
Put the entire file system in no-history mode. Change
history is not retained. Use of this option may increase
the overhead of doing mirroring. This option is gener-
ally only used in an emergency.
Assign a master id for the entire mount which applies to
all PFSs under the mount. This is intended to help sup-
port multi-master and fail-over operation. Multi-master
operation is not yet supported. If you intend to upgrade
slaves to masters and downgrade masters to slaves as part
of a fail-over setup, it's a good idea to assign a dif-
ferent master id to the HAMMER mounts making up the fail-
By default a HAMMER mount assigns a master id of 0. You
can force no-mirror operation by specifying this option.
This option disables mirror transaction id propagation in
the B-Tree and will improve write performance somewhat
but also prevents incremental mirroring from working at
all, and is not recommended.
Mount the file system as-of a particular transaction id. The
mount will automatically be made read-only. The transaction-id
must be specified as a 64 bit hex value prefixed with "0x".
-u Update the mount point. This is typically used to upgrade a
mount to read-write or downgrade it to read-only.
Note that issuing a read-only mount which requires UNDOs to be run will
still run the UNDOs, but will not flush the buffer cache buffers until/if
the mount is updated to read-write.
The mount_hammer utility exits 0 on success, and >0 if an error occurs.
Mount a HAMMER file system made up of two volumes onto /mnt:
mount_hammer -o ro,noatime /dev/ad0s1d /dev/ad1s1d /mnt
Above is equivalent to below using blkdevs format for HAMMER volumes as
mount_hammer supports both formats.
mount_hammer -o ro,noatime /dev/ad0s1d:/dev/ad1s1d /mnt
A corresponding fstab(5) entry is:
/dev/ad0s1d:/dev/ad1s1d /mnt hammer ro,noatime
mount(2), unmount(2), fstab(5), HAMMER(5), disklabel(8), disklabel64(8),
fdisk(8), gpt(8), hammer(8), mount(8), newfs_hammer(8)
The mount_hammer utility first appeared in DragonFly 1.11.
Matthew Dillon <email@example.com>
DragonFly 5.5 December 31, 2015 DragonFly 5.5