DragonFly On-Line Manual Pages
NG_TEE(4) DragonFly Kernel Interfaces Manual NG_TEE(4)
ng_tee -- netgraph ``tee'' node type
The tee node type has a purpose similar to the tee(1) command. Tee nodes
are useful for debugging or ``snooping'' on a connection between two net-
graph nodes. Tee nodes have four hooks, right, left, right2left, and
left2right. All data received on right is sent unmodified to both hooks
left and right2left. Similarly, all data received on left is sent unmod-
ified to both right and left2right.
Packets may also be received on right2left and left2right; if so, they
are forwarded unchanged out hooks right and left, respectively.
This node type supports the following hooks:
right The connection to the node on the right.
left The connection to the node on the left.
right2left Tap for right to left traffic.
left2right Tap for left to right traffic.
This node type supports the generic control messages, plus the following.
Get statistics, returned as a struct ng_tee_stats.
This node shuts down upon receipt of a NGM_SHUTDOWN control message, or
when all hooks have been disconnected.
tee(1), netgraph(4), ngctl(8)
The ng_tee node type was implemented in FreeBSD 4.0.
Julian Elischer <julian@FreeBSD.org>
DragonFly 4.7 January 19, 1999 DragonFly 4.7