DragonFly On-Line Manual Pages
OCE(4) DragonFly Kernel Interfaces Manual OCE(4)
oce -- Device driver for Emulex OneConnect 10Gb network adapters
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
Emulex OneConnect adapters come in various skews and with different com-
binations of NIC, FCoE and iSCSI functions. The oce driver claims the
NIC functions in all these adapters.
The oce driver supports TCP checksum offload, Bonding, and Jumbo frames
(from 1500 - 9000).
The oce driver supports the following network adapters:
* Emulex BladeEngine 2
* Emulex BladeEngine 3
* Emulex Lancer
Adapter firmware updates are persistent.
Firmware can be updated by following the steps below:
1. Copy the below code to a Makefile:
2. Replace imagename in above with UFI file name
3. Copy Makefile and UFI file to a directory
4. Execute make & make install
5. sysctl dev.oce.<if_id>.fw_upgrade=elxflash
6. Reboot the machine
In case of issues with supplied UFI, flashing fails with one of the fol-
1. "Invalid BE3 firmware image"
2. "Invalid Cookie. Firmware image corrupted ?"
3. "cmd to write to flash rom failed."
For general information and support, go to the Emulex website at:
http://www.Emulex.com/ or E-Mail at email@example.com.
The oce driver was written by firstname.lastname@example.org.
DragonFly 5.1 November 28, 2014 DragonFly 5.1