DragonFly On-Line Manual Pages
PCTRACK(8) DragonFly System Manager's Manual PCTRACK(8)
pctrack -- print kernel system/interrupt PC sampling history
pctrack [-fnsi] [-c cpu] [-N execfile] [-M corefile] [interval]
Kernels compiled with DEBUG_PCTRACK record the program counter (PC) of
the code interrupted by the statistics clock interrupt. This information
can be dumped with the pctrack utility
The following options are available:
-c cpu Specify which CPU to dump. If not specified, all CPUs will
-f If a single CPU and either -i or -s is specified, this
option will use the repeat interval to detect changes and
dump them as they occur.
-i Dump the interrupt tracking buffer.
-s Dump the kernel tracking buffer. If neither -i or -s is
specified, both tracking buffers will be dumped.
-n pctrack normally tries to translate the PC into symbols.
This option forces hex values to be displayed instead.
-N execfile The kernel image to resolve symbols from. The default is
the value returned via getbootfile(3).
-M corefile The core file or memory image to read from. The default is
The pctrack utility first appeared in DragonFly 1.5.
The pctrack utility was originally implemented by Matthew Dillon for
DragonFly 4.7 June 8, 2006 DragonFly 4.7