DragonFly On-Line Manual Pages
REBOOT(8) DragonFly System Manager's Manual REBOOT(8)
reboot, halt, fastboot, fasthalt -- stopping and restarting the system
halt [-lnqp] [-k kernel]
reboot [-dlnqp] [-k kernel]
fasthalt [-lnqp] [-k kernel]
fastboot [-dlnqp] [-k kernel]
The halt and reboot utilities flush the file system cache to disk, send
all running processes a SIGTERM (and subsequently a SIGKILL) and, respec-
tively, halt or restart the system. The action is logged, including
entering a shutdown record into the wtmp(5) file.
The options are as follows:
-d The system is requested to create a crash dump. This option is
supported only when rebooting, and it has no effect unless a dump
device has previously been specified with dumpon(8).
Boot the specified kernel on the next system boot. If the kernel
boots successfully, the default kernel will be booted on succes-
sive boots, this is a one-shot option. If the boot fails, the
system will continue attempting to boot kernel until the boot
process is interrupted and a valid kernel booted. This may
change in the future.
-l The halt or reboot is not logged to the system log. This option
is intended for applications such as shutdown(8), that call
reboot or halt and log this themselves.
-n The file system cache is not flushed. This option should proba-
bly not be used.
-q The system is halted or restarted quickly and ungracefully, and
only the flushing of the file system cache is performed (if the
-n is not specified). This option should probably not be used.
-p The system will turn off the power if it can. This is of course
likely to make reboot rather similar to halt.
The fasthalt and fastboot utilities are nothing more than aliases for the
halt and reboot utilities.
Normally, the shutdown(8) utility is used when the system needs to be
halted or restarted, giving users advance warning of their impending doom
and cleanly terminating specific programs.
wtmp(5), boot(8), dumpon(8), savecore(8), shutdown(8), sync(8)
A reboot command appeared in 4.0BSD.
DragonFly 4.9 September 29, 2016 DragonFly 4.9