DragonFly On-Line Manual Pages
RNDCONTROL(8) DragonFly System Manager's Manual RNDCONTROL(8)
rndcontrol -- a utility for manipulating the /dev/random device
rndcontrol [-q] [-s irq_no] [-c irq_no]
The rndcontrol command is used to set which interrupts are used to help
add entropy to the CSPRNG maintained by the kernel. The /dev/random and
/dev/urandom devices are the user interface to this source of randomness.
Any changes take effect immediately.
The following command line options are supported:
-q Turn off all output except errors.
-s n Allow IRQ n to be used as a source of randomness. This option
may be repeated for more than one IRQ.
-c n Stop IRQ n from being used as a source of randomness. This
option may be repeated for more than one IRQ.
By default, all IRQs will help develop entropy. The kernel uses a rate-
limited helper thread to add the actual entropy and even fast interrupts
should not detrimentally affect a running system.
/dev/random secure random device
/dev/urandom random device
The rndcontrol utility first appeared in FreeBSD 2.1.5.
Theodore Ts'o wrote the core code. Mark Murray ported this code to
FreeBSD and wrote the support routines and constructed the man pages.
Sure to be some.
DragonFly 5.3 October 20, 1995 DragonFly 5.3