DragonFly On-Line Manual Pages
SYSCTL.CONF(5) DragonFly File Formats Manual SYSCTL.CONF(5)
sysctl.conf -- kernel state defaults
The /etc/sysctl.conf file is read in when the system goes into multi-user
mode to set default settings for the kernel. The /etc/sysctl.conf is in
the format of the sysctl(8) command, i.e.
Comments are denoted by a ``#'' at the beginning of a line. Comments can
also exist at the end of a line, as seen in the EXAMPLES section, below.
/etc/sysctl.conf Initial settings for sysctl(8).
To turn off logging of programs that exit due to fatal signals you may
use a configuration like
# Configure logging.
kern.logsigexit=0 # Do not log fatal signal exits (e.g. sig 11)
rc.conf(5), rc(8), sysctl(8)
The sysctl.conf file appeared in FreeBSD 4.0.
If loadable kernel modules are used to introduce additional kernel func-
tionality and sysctls to manage that functionality, sysctl.conf may be
processed too early in the boot process to set those sysctls. For exam-
ple, sysctls to manage the linux emulator cannot be set in sysctl.conf if
the linux emulator is loaded as a module rather than compiled into the
DragonFly 4.7 December 30, 1999 DragonFly 4.7