DragonFly On-Line Manual Pages
TWS(4) DragonFly Kernel Interfaces Manual TWS(4)
tws -- 3ware 9750 series SATA/SAS RAID controllers driver
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The tws driver provides support for LSI's 3ware 9750 series SATA/SAS con-
These controllers are available in 4, 8, 16 or 24-port configurations,
and support the following RAID levels: 0, 1, 10, 5, 50, 6. The device
nodes for the controllers are of the form /dev/twsX, where X is the con-
troller number. The driver is implemented as a SCSI SIM under CAM, and,
as such, the logical units that it controls are accessible via the device
nodes, /dev/daY, where Y is the logical unit number.
By default, the driver will use MSI if it is supported. This
behavior can be turned off by setting this tunable to 0.
The tws driver supports the following SATA RAID controllers:
* LSI's 3ware SAS 9750-4i
* LSI's 3ware SAS 9750-4i4e
* LSI's 3ware SAS 9750-8i
* LSI's 3ware SAS 9750-8e
* LSI's 3ware SAS 9750-16i4e
* LSI's 3ware SAS 9750-24i4e
da(4), twa(4), twe(4)
Copyright (c) 2010, LSI Corp.
All rights reserved.
Author : Manjunath Ranganathaiah
Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions
1. Redistributions of source code must retain the above copyright
notice, this list of conditions and the following disclaimer.
2. Redistributions in binary form must reproduce the above copyright
notice, this list of conditions and the following disclaimer in
the documentation and/or other materials provided with the
3. Neither the name of the <ORGANIZATION> nor the names of its
contributors may be used to endorse or promote products derived
from this software without specific prior written permission.
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.
DragonFly 4.7 January 14, 2013 DragonFly 4.7