DragonFly On-Line Manual Pages
UCHCOM(4) DragonFly Kernel Interfaces Manual UCHCOM(4)
uchcom -- WinChipHead CH341/CH340 serial adapter driver
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The uchcom driver provides support for the WinChipHead CH341/CH340 USB-
to-RS-232 Bridge chip.
The device is accessed through the ucom(4) driver which makes it behave
like a tty(4).
The uchcom driver supports the following adapters:
* HL USB-RS232
tty(4), ucom(4), usb(4)
The uchcom driver first appeared in NetBSD 5.0 and was imported into
DragonFly 1.11. The first FreeBSD release to include it was FreeBSD 8.0.
Actually, this chip seems unable to drive other than 8 data bits and 1
stop bit line.
DragonFly 4.7 November 20, 2011 DragonFly 4.7