DragonFly On-Line Manual Pages
ULPT(4) DragonFly Kernel Interfaces Manual ULPT(4)
ulpt -- USB printer support
To compile this driver into the kernel, place the following line in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The ulpt driver provides support for USB printers that follow the printer
bi- or uni-directional protocol. The bits in the minor number select
various features of the driver.
Minor Bit Function
64 Do not initialize (reset) the device on the port.
Some printers cannot handle the reset on open; in case of problems try
the unlpt device.
The ulpt driver provides support for USB printers and parallel printer
conversion cables, including the following:
* ATen parallel printer adapter
* Belkin F5U002 parallel printer adapter
* Canon BJ F850, S600
* Canon LBP-1310, 350
* Entrega USB-to-parallel printer adapter
* Hewlett-Packard HP Deskjet 3420 (P/N: C8947A #ABJ)
* Oki Data MICROLINE ML660PS
* Seiko Epson PM-900C, 880C, 820C, 730C
/dev/ulpt? device with reset
/dev/unlpt? device without reset
The ulpt driver appeared in NetBSD 1.4. This manual page was adopted
from NetBSD by Tom Rhodes <trhodes@FreeBSD.org> in April 2002.
DragonFly 4.7 November 22, 2006 DragonFly 4.7