DragonFly On-Line Manual Pages
UMS(4) DragonFly Kernel Interfaces Manual UMS(4)
ums -- USB mouse driver
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The ums driver provides support for mice that attach to the USB port.
Supported are mice with any number of buttons and mice with a wheel.
The /dev/ums0 device presents the mouse as a sysmouse or mousesystems
type device. See moused(8) for an explanation of these mouse types.
/dev/ums0 blocking device node
Use the first USB mouse on the system as your console mouse:
moused -p /dev/ums0 -t auto
To be able to use the USB mouse under X, change the "Pointer" section in
xorg.conf to the following:
If you want to be able to use the mouse in both virtual consoles as well
as in X change it to:
ohci(4), sysmouse(4), uhci(4), usb(4), xorg.conf(5) (x11/xorg), moused(8)
The ums driver was written by Lennart Augustsson
<firstname.lastname@example.org> for NetBSD and was adopted for FreeBSD by
MAEKAWA Masahide <email@example.com>.
This manual page was written by Nick Hibma <n_hibma@FreeBSD.org> with
input from Kazutaka YOKOTA <firstname.lastname@example.org>.
DragonFly 5.1 March 11, 2014 DragonFly 5.1