DragonFly On-Line Manual Pages
URNDIS(4) DragonFly Kernel Interfaces Manual URNDIS(4)
urndis -- USB Remote NDIS Ethernet device
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The urndis driver provides Ethernet access over Remote NDIS (RNDIS),
allowing mobile devices such as phones and tablets to provide network
access. It is often referred to as USB tethering, and in most cases must
be explicitly enabled on the device.
urndis should work with any USB RNDIS devices, such as those commonly
found on Android devices. It does not support different media types or
options. For more information on configuring this device, see
arp(4), netintro(4), usb(4), ifconfig(8)
The urndis device driver first appeared in OpenBSD 4.7. The first
FreeBSD release to include it was FreeBSD 9.3.
The urndis driver was written by Jonathan Armani <firstname.lastname@example.org>,
Michael Knudsen <email@example.com>, and Fabien Romano <firstname.lastname@example.org>.
It was ported to FreeBSD by Hans Petter Selasky <hps@FreeBSD.org>.
DragonFly 5.1 July 7, 2014 DragonFly 5.1