DragonFly On-Line Manual Pages
USBD(8) DragonFly System Manager's Manual USBD(8)
usbd -- supervise USB attach/detach
usbd [-c configfile] [-d] [-e] [-f device] [-n] [-t timeout] [-v]
The usbd utility handles USB device attachment and detachment. The (mul-
tiple) -f device command line options specify which controllers it should
handle. Normally this option is not needed.
If the ``usb'', ``ohci'' and ``uhci'' modules are not loaded, usbd will
load them automatically.
To handle the attachment and detachment of USB devices usbd opens the
/dev/usb device and reads events from it. Whenever a device is attached
or detached the list of actions read from /etc/usbd.conf is searched for
a matching entry. If found, the corresponding action is executed.
The command line options are as follows:
Name of configuration file. The default is /etc/usbd.conf.
-d Enable debugging to the standard output, and do not disassociate
from the controlling terminal.
-e Do one device tree exploration, no event queue handling and then
Specify the pathname of a USB controller device file. The flag
may be repeated to watch more than one USB controller. The
default is /dev/usb0 through /dev/usb3. Do not specify the
device /dev/usb here. It is used for events only.
-n Do not handle the event queue on /dev/usb.
Set the timeout interval (in seconds) before an exploration hap-
pens without being triggered by a connect or disconnect. A time-
out of 0 means that there is no timeout. The default is 30.
-v Be verbose. Repeating the flag makes usbd more verbose.
The usbd utility appeared in NetBSD 1.4.
The usbd driver was written by Lennart Augustsson <email@example.com>
for the NetBSD project. The event queue handling in usbd was added by
Nick Hibma <n_hibma@FreeBSD.org>.
DragonFly 3.7 July 2, 2006 DragonFly 3.7