DragonFly On-Line Manual Pages
VOP_INACTIVE(9) DragonFly Kernel Developer's Manual VOP_INACTIVE(9)
VOP_INACTIVE, VOP_RECLAIM -- reclaim filesystem resources for a vnode
VOP_INACTIVE(struct vnode *vp);
VOP_RECLAIM(struct vnode *vp);
The arguments are:
vp the vnode being reclaimed
VOP_INACTIVE(9) is called when the kernel is no longer using the vnode.
This may be because the reference count reaches zero or it may be that
the filesystem is being forcibly unmounted while there are open files.
It can be used to reclaim space for 'open but deleted' files.
VOP_RECLAIM(9) is called when a vnode is being reused for a different
filesystem. Any filesystem specific resources associated with the vnode
should be freed.
This man page was written by Doug Rabson.
DragonFly 4.9 November 15, 2014 DragonFly 4.9