DragonFly On-Line Manual Pages
DEVCLASS(9) DragonFly Kernel Developer's Manual DEVCLASS(9)
devclass -- object representing a class of devices
typedef struct devclass *devclass_t;
The devclass object has two main functions in the system. The first is
to manage the allocation of unit numbers for device instances and the
second is to hold the list of device drivers for a particular bus type.
Each devclass has a name and there cannot be two devclasses with the same
name. This ensures that unique unit numbers are allocated to device
devclass_add_driver(9), devclass_delete_driver(9), devclass_find(9),
devclass_find_driver(9), devclass_get_device(9), devclass_get_devices(9),
devclass_get_maxunit(9), devclass_get_name(9), devclass_get_softc(9),
This man page was written by Doug Rabson.
DragonFly 5.3 June 16, 1998 DragonFly 5.3