DragonFly On-Line Manual Pages
DEVICE_GET_STATE(9) DragonFly Kernel Developer's Manual DEVICE_GET_STATE(9)
device_get_state, device_busy, device_unbusy, device_is_alive -- manipu-
late device state
The current state of a device is accessed by calling device_get_state(9)
which returns DS_NOTPRESENT, DS_ALIVE, DS_ATTACHED or DS_BUSY (described
in device(9)). To test see if a device was successfully probed, call
device_is_alive(9) which simply returns if the state is greater or equal
Each device has a busy count which is incremented when device_busy(9) is
called and decremented when device_unbusy(9) is called. Both routines
return an error if the device state is less than DS_ATTACHED.
When device_busy(9) is called on a device in the DS_ATTACHED state, the
device changes to the DS_BUSY state. When device_unbusy(9) is called and
after decrementing, the busy count for the device is zero, the device
changes to the DS_ATTACHED state.
This man page was written by Doug Rabson.
DragonFly 4.9 June 16, 1998 DragonFly 4.9