DragonFly BSD

UsingQupzilla

Installation

As of the writing of this document, Qupzilla is in dports as www/qupzilla-qt4 and www/qupzilla-qt5.

Binary package

As root, depending on the Qt version you want to use you. See below the installation for Qupzilla based on Qt4.

# pkg install qupzilla-qt4

Building from source

A Dports checkout/tarball is needed for this, usually you can get it easily by following the instructions in /usr/Makefile:

# cd /usr
# make help

To install (below Qt4 has been used):

# cd /usr/dports/www/qupzilla-qt4
# make BATCH=yes install clean

You can also use synth to install it (below Qt4 has been used):

# cd ~
# synth install www/qupzilla-qt4

Configuration

Always check what the pkg-message of the package says. It will give some recommendations for the setup.

# pkg info -D qupzilla-qt4

For Firefox specifically bear in mind that IPC in FreeBSD works differently as it works in DragonFly BSD.

Security

Besides the usual recommendations for web browsing security, we've created also a way of setting up Chromium to minimize the risks of exposure to certain vulnerabilities (Spectre, Meltdown) among other things. Please see: RunSecureBrowser Similar guidelines could be applied to any other browser although they may not have the same security mechanisms Chromium has.

Known issues

Please list down all the problems there might be with this browser below.

BugURL Description Workaround Status