DragonFly BSD
DragonFly bugs List (threaded) for 2004-02
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: cant buildworlnd on FreeBSD 4.9-RELEASE

From: Matthew Dillon <dillon@xxxxxxxxxxxxxxxxxxxx>
Date: Wed, 4 Feb 2004 23:07:44 -0800 (PST)

    This is probably me being a bit overzealous on the FreeBSD->DragonFly
    changes.  I will definitely be able to fix it once I get back next
    week, but if another cmomitter wants to have at it that's ok too (it's
    just a matter of finding the FreeBSD->DragonFly changes related to the
    bootstrap tools, aka the C compiler, and make them FreeBSD && DragonFly
    instead.  e.g. #if defined(__FreeBSD__) was converted to
    #if defined(__DragonFly__) but for bootstrap tools should really
    be #if defined(__FreeBSD__) || defined(__DragonFly__).

					Matthew Dillon 
:===> lib/csu/i386-elf
:cc -O -pipe -march=k6 -elf -Wall -fkeep-inline-functions 
:-I/spool/dragonfly/src/lib/csu/i386-elf/../common  -c crt1.c -o crt1.o
:In file included from crt1.c:35:
:`__DragonFly_version' undeclared here (not in a function)
:initializer element is not constant
:/spool/dragonfly/src/lib/csu/i386-elf/../common/crtbrand.c:52: (near 
:initialization for `abitag.desc')
:*** Error code 1

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]