DragonFly BSD
DragonFly bugs List (threaded) for 2004-07
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: DFBSD on 2nd drive fails to boot, FreeBSD succeeds same partition

From: Chris Pressey <cpressey@xxxxxxxxxxxxxxx>
Date: Wed, 28 Jul 2004 15:28:29 -0700

On Wed, 28 Jul 2004 14:21:18 -0700 (PDT)
Matthew Dillon <dillon@xxxxxxxxxxxxxxxxxxxx> wrote:

> :> | Seeing if ad1s2 needs to be created...
> :> | No, ad1s2 already exists
> :> `->>> Exit status: 0
> :> 
> :> ,-<<< Executing 'mount /dev/ad1s2a /mnt'
> :> | mount: /dev/ad1s2a : No such file or directory
> :> `->> Exit status: 1
> :
> :Does it help if you manually "cd /dev && ./MAKEDEV ad1s2a" before
> using:the installer?  From this it looks like it somehow skipped
> making that:device node... I thought we caught all these cases, all
> but maybe not.
>     It looks like the installer is testing ad1s2 and assuming that
>     ad1s2a exists if ad1s2 does, but in fact this is not necessarily
>     the case.  MAKEDEV by default will create ad1s2 but not
>     ad1s2{partition}.

It looks that way, but the part of the log shown is actually generated
from two independent parts of the installer.  The 'mount' bit has no
direct relation to the 'maybe_makedev' bit.

Pete, I need to know exactly what you were trying to do when you got the

	Execution of the command
	mount /dev/ad1s2a /mnt
	FAILED with a return code of 1

in order to figure this out (was it "Configure an Installed System" by
any chance?)


[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]