DragonFly BSD
DragonFly bugs List (threaded) for 2004-08
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: re driver woes

From: Shawn <adonijah@xxxxxxxxx>
Date: Mon, 02 Aug 2004 19:55:36 -0500

On Mon, 02 Aug 2004 17:13:19 -0700, Matthew Dillon wrote:

> :Mine comes up initially with a media of Autoselect 10/100 (something like
> :that), after several minutes it sets status to
> :"no carrier", and then finally sets media to: "Ethernet autoselect
> :(100baseTX <full-duplex>)" and status: "active".
> :
> :I then try to run dhclient on it, and it just hangs forever. DHCP works
> :under Linux / Windows for this so I'm not sure what to do. The driver
> :hasn't worked since I've tried the version in CVS, for whatever reason the
> :version you sent to me before committing worked.
> :
> :I should clarify that this is an integrated Gigabit Ethernet Controller as
> :this is a Gigabyte K8NPro NForce 3 Pro 150 Chipset motherboard.
>     The media mode is a function of the Phy/MII layer.  If you are seeing
>     fluctuations *prior* to running dhclient, there's a good chance that
>     it is actually a problem with the cable.  If you have some way to
>     test/replace the cable I would try that.

dhclient now works with Joerg's latest code update (not using mmap for re
interface IO), but regardless of the cable I use (homemade or
manufactured) detection still takes longer than it does under other
operating systems. I'll have to play around with it some more to give a
more exact feeling of how long.

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]