DragonFly BSD
DragonFly bugs List (threaded) for 2005-02
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: Problem with bsd.ports.mk

From: Guillermo Garcia Rojas <garciarojas@xxxxxxxxxxx>
Date: Thu, 24 Feb 2005 10:51:33 -0600

I reinstalled yesterday and all went fine. It's working now.

On Wed, 23 Feb 2005 16:41:32 -0800, walt wrote:

> Jeroen Ruigrok/asmodai wrote:
>> -On [20050223 15:42], YONETANI Tomokazu (qhwt+dfly@xxxxxxxxxx) wrote:
>>>I just committed a fix for libtool15, which was using <bsd.port.mk>
>>>instead of <bsd.dfport.mk>.
>> Ahh, arigatou YONETANI-san.
> We are very lucky to have such a master detective on the DFly team.
> I just reinstalled libtool15 after cvsup'ing and I was hoping that
> it would solve the problem I posted to users@ this morning, but it
> did not :o(
> To recap briefly:  while building the libgnome port I get an error
> due to a missing -pthread flag.  If I add the -pthread flag by hand
> it all works fine.
> The place I chose to add the '-pthread' was in the file libgnome-2.la,
> which of course was generated by libtool15.
> My question is:  is the .la file the proper place for a '-pthread',
> or should it go in a Makefile?  In either case there is a problem
> with the libgnome port and I would love to understand exactly what
> the problem is so I can submit patches instead of complaints ;o)
> Thanks!

Powered by DragonFly BSD

Guillermo Garcia-Rojas

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]