DragonFly BSD
DragonFly bugs List (threaded) for 2005-02
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: Problem with atapicam burning CD and DVD.

From: Michael Powell <nightrecon@xxxxxxxxxxx>
Date: Mon, 28 Feb 2005 09:45:14 -0500

Steve O'Hara-Smith wrote:

> Hi,
> First the good news - I installed Dragonly 1.1-stable from an
> ISO found on a mirror site on Fri 25 Feb on an AMD64/ASUS A8V Deluxe/
> Maxtor 200GB SATA/LG GSA-4163B DVD burner setup. The moherboard is the
> VIA KT800Pro/VT8233 variant with Socket 939. Everything on the
> motherboard works fine (LAN, Sound, SATA, USB, Firewire, ACPI, the lot)
> using the shipped generic kernel and a few modules. --- Thank you and
> well done to all.
> Now the bad news :)
> Attempts to burn DVDs or CDs via atapicam fail with errors that
> seem to point to problems with the pass mechanism. For example:
> root@df1# growisofs -dvd-compat -Z /dev/cd0c dvd
> :-( unable to CAMGETPASSTHRU for /dev/cd0c: Inappropriate ioctl for
> :device
> root@df1# cdrecord -scanbus
> Cdrecord 2.00.3 (i386-unknown-freebsd4.8) Copyright (C) 1995-2002 Jrg
> Schilling cdrecord: Inappropriate ioctl for device. CAMIOCOMMAND ioctl
> failed. Cannot open
>  SCSI driver.
> cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you
> are root. cdrecord: For possible transport specifiers try 'cdrecord
> dev=help'.
> cdrecord dev=1,0,0 test.iso
> Cdrecord 2.00.3 (i386-unknown-freebsd4.8) Copyright (C) 1995-2002 Jrg
> Schilling scsidev: '1,0,0'
> scsibus: 1 target: 0 lun: 0
> Using libscg version 'schily-0.7'
> cam_periph_mapmem: error, address 0, length 0 isn't user accessible for
> WRITE cdrecord: Permission denied. Cannot send SCSI cmd via ioctl


   Recently I did a new install of 2CSNAP-20041218-2330-GCC2.iso, 
cvsupped to Dragonfly-Stable and rebuilt world/kernel/etc. Last week when
I was installing desktop software from ports I had similar difficulties
with K3b and xcdroast. I setuid cdrdao, cdrecord, readcd, and scgcheck.
Then when I ran K3b from a terminal prompt it complained, in turn, about
permissions problems. I chmod 660 the /dev/cd0c, pass(x), sa(x), xpt(x)
devices, added my user account to the operators group and my atapicam
cdburning is presently working with K3b and xcdroast.

   Initially my problems began with cdrecord/readcd not able to see the
burner at all, as if it wasn't present. Your problem may be different
from mine. 

   My hardware here is a Sempron 2800+ on a KD7A (KT-400A) mobo with 256MB
Ram. The CD Burner is a Sony CRX215E1. I have all of the KDE desktop with
various other apps installed and am quite pleased with my results. I'm
even using the nvidia-driver from the ports override. I had a problem
with sound "spitching" that was solved by installing 4Front's OSS driver.
I believe the "feedrate" code for the pcm/via_8233 code was a hack where
timing was worked out on older hardware and the parameters are not right
for a faster processor. The other problem I had was the NTFS kernel code
spewing lots of console errors and sometimes rebooting the machine on an
unmount. Removing the entry from the kernel config and using the ntfs.ko
module instead took care of that. But I am very happy with my "new"
junkbox.   :-)


[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]