DragonFly BSD
DragonFly bugs List (threaded) for 2006-09
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: Lockups related to (possibly IDE issues) ?

From: nospam@xxxxxxxxxxxxx (Jamie)
Date: 08 Sep 2006 15:09:42 GMT

In <20060908135606.GS58690@xxxxxxxxxx>,
YONETANI Tomokazu <qhwt+dfly@xxxxxxxxxx> mentions:
>On Fri, Sep 08, 2006 at 12:13:13PM +0000, Jamie wrote:
>> I'm actually not sure if this is a bug or something I've messed up. 
>> Things were working until I apparently had a hard drive failure, replaced
>> Hard drive (drive as master and CDROM as the slave, both on IDE0).
>> There is no sound card, there is only a 3Com PCI card plus the other components
>> of a bare machine. (VGA card and the motherboard IDE, there aren't any
>> USB ports that I can see)
>> The drive is a MAXTOR  200G, with the first 50G being used for the OS (primary
>> partition) Setup as master = LBA, slave = AUTO in BIOS. (The BIOS can't see the
>> full drive.)
>> Seemed to lock up at random times during the install process, almost always when
>> copying files from the distribution CD, eventually I was able to get it
>> installed, only to see it lock up when it probed the CDROM (by this time,
>> booting from hard drive)
>> I inserted a CD in the drive, wondering if it was choking on the no media found,
>> booted again, this time it loaded and I got to the login prompt. (again, booting
>> from hard drive)
>> Then it locked up just as I entered the password.
>I assume you're using 1.6.x-RELEASE, right?

Yes, the most current CD ISO image. (I'm unable to get far enough along to update 
the software)

It's this image: dfly-1.6.0_REL.iso

>> This machine seems to have a pretty decent BIOS.
>> Bios settings:
>> Power Management: OFF 
>> ACPI I/O Device Node is OFF. (I've experimented with this, so far, no dif.)
>Does this actually turn off ACPI driver?  When ACPI driver is disabled,
>sysctl hw.acpi gives you nothing:
># sysctl hw.acpi
>sysctl: unknown oid 'hw.acpi'

That is correct:

sysctl: unknown oid 'hw.acpi' (Able to do this only with the boot CD)

(How in the world do you remember all those variables? :-) )

Someone else asked if I had Linux installed in the same partition:

Linux is on /dev/hda2 and DragonFly is /dev/hda1 (not sure exactly what
those equate to in terms of dragonflyBSD devices, it's the first partition

On a whim, I tried disconnecting the CDROM entirely, no difference. Locked up
part way in to the system checks. (trying to correct itself from the time it
froze on the password login I'd imagine) 

Is there a limitation on the size of disklabel slices that I missed?
---------------|partition 1| (disk label)-----
4G  / 
8G  /var
1G  /tmp
12G /usr
768M swap
24-25G /home
Total: 50G on partition 1.

I've downloaded FreeBSD version 6.1 beta (6.1-BETA1-i386-disc1.iso) I'll try
installing that and see if it goes. Maybe that'll show something? 

http://www.geniegate.com                    Custom web programming
guhzo_42@xxxxxxxxx (rot13)                User Management Solutions

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]