DragonFly bugs List (threaded) for 2009-01
DragonFly BSD
DragonFly bugs List (threaded) for 2009-01
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: Hammer boot cannot load modules anymore

To: Simon 'corecode' Schubert <corecode@xxxxxxxxxxxx>
From: Michael Neumann <mneumann@xxxxxxxx>
Date: Sat, 10 Jan 2009 18:45:13 +0100

Simon 'corecode' Schubert schrieb:
Michael Neumann wrote:

I'm using the pure Hammer bootloader.

At first it worked, but now, after using the system for a while I cannot load modules at boot time anymore. So I always have to disable acpi, otherwise it will hang shortly after showing some progress trying to load the module (it just shows a few "/", "|", backslash, "-" characters, then it hangs).

can you ctrl-alt-del the machine at that point or is it locked?

Yes that works.

The kernel itself boots just fine. I am using the GENERIC kernel.

I'm not sure how to debug this... If your file system is small enough, you could put it up somewhere for me to have a look. Alternatively you can build a standalone hammer reader from the boot source in lib/libstand/hammerread.c and try to debug why it can't load the modules. I guess it has something to do with the btree layout.

I have problems compiling hammerread:

  cd lib/libstand
  make -DTESTING -DDEBUG=3 hammerread

/usr/libexec/binutils217/elf/ld: errno: TLS definition in /usr/lib/libc.so section .tbss mismatches non-TLS reference in /tmp//ccVzucFt.o
/usr/lib/libc.so: could not read symbols: Bad value

What am I doing wrong?



[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]