DragonFly BSD
DragonFly bugs List (threaded) for 2012-11
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

[DragonFlyBSD - Bug #2450] (Closed) building 3.2 release on master fails

From: John Marino via Redmine <bugtracker-admin@xxxxxxxxxxxxxxxxxxxxx>
Date: Thu, 15 Nov 2012 09:32:29 -0800

Issue #2450 has been updated by John Marino.

Status changed from New to Closed

It is possible to build RELEASE 3.2 from master now.
Also confirmed building from previous to 3.2.1 release also works.


first commit is cherry-pick, second commit is unique to release 3.2.
Only the minimum number of bmake changes were brought in to support parallel-building of world.  Without -j, only the bsd.cpu.mk file needed updating.

Bug #2450: building 3.2 release on master fails

Author: Thomas Nikolajsen
Status: Closed
Priority: Normal
Assignee: John Marino
Target version: 

Using master of October 30 buildworld of 3.2 release fails,
see below for make output.

It seems like problem is that new make (aka bmake)
isn't backward compatible with old make,
e.g. .makeenv command isn't supported.
(after adding this command to bmake, buildworld fails later in build)

$ head -56 /usr/src/share/mk/bsd.cpu.mk | tail -2
.makeenv CCVER
.makeenv HOST_CCVER

- make -j 10 buildworld
--- buildworld ---
make: "/usr/src/share/mk/bsd.cpu.mk" line 55: Unknown directive
make: "/usr/src/share/mk/bsd.cpu.mk" line 56: Unknown directive
make: Fatal errors encountered -- cannot continue
make: stopped in /usr/src
*** [buildworld] Error code 1

make: stopped in /usr/src

make: stopped in /usr/src

You have received this notification because you have either subscribed to it, or are involved in it.
To change your notification preferences, please click here: http://bugs.dragonflybsd.org/my/account

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]