DragonFly kernel List (threaded) for 2004-01
Re: call for API review: new bitstring functions
On Monday 05 January 2004 06:09, Jeffrey Hsu wrote:
> - We'd have to name it something obscure like bit_rffs and bit_rfls
> to preserve consistency with the existing naming convention.
> I am reminded of Ken Thompson's reply at his Turing award acceptance
> ceremony, when asked what he'd do differently about Unix, he replied
> he'd spell "creat" with an "e". Now that compilers and linkers
> don't have a short limit on symbol names, naming new functions
> after instructions from an obsolete computer architecture seems
> like bad practice.
I liked the idea after all.
$grep -r "<bitstring.h>" | wc -l # 134 matches
$grep -r "<bitstring.h>" | grep -v contrib/nvi | wc -l # 7 matches
Indicates the bitstring.h isn't that famous at all. So maybe it's time to
build a new, shinny bitstring API for the masses?! I guess there are quite a
few local bitstring hacks out there, some of which are far from being well
done, for sure.
I wonder if there is interest in a good, fast and usable bitstring API?
Comments, interest, feature-requests (apart from "range")?
Best regards, | max@xxxxxxxxxxxxxx
Max Laier | ICQ #67774661
http://pf4freebsd.love2party.net/ | mlaier@EFnet #DragonFlyBSD