DragonFly BSD
DragonFly kernel List (threaded) for 2005-04
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]


From: Matthew Dillon <dillon@xxxxxxxxxxxxxxxxxxxx>
Date: Sun, 10 Apr 2005 10:10:35 -0700 (PDT)

:-On [20050409 02:32], Matthew Dillon (dillon@xxxxxxxxxxxxxxxxxxxx) wrote:
:>    http://www.dragonflybsd.org/main/release1_2.cgi
:You say GCC 2.95.4 will be dropped.
:Cool.  Can I rip out freebsd-4.8 from our dfports override stuff?  Since GCC
:3.x does not have any freebsd compability in it at all and we need to fix up
:a lot of ports, better to force this now instead of doing that in a little
:while.  (And yes, I am constantly running into a lot of issues with the
:crutch that are the overrides with this freebsd added work-around.)
:Jeroen Ruigrok van der Werven <asmodai(at)wxs.nl> / asmodai / kita no mono

    I don't think we want to rip up our dfports stuff until we actually
    have something to replace it with.

    I'm not sure I understand what you mean about gcc 3.x not having any
    freebsd compatibility.  Binaries compiled with gcc 3.x work just fine
    on a FreeBSD-4.x box.  Maybe you are thinking of the FreeBSD-5 signal
    changes that broke FreeBSD 5's backwards compatibility with FreeBSD-4
    (and now also new system calls that are made unconditionally in FreeBSD-5
    which also break compatibility with FreeBSD-4).

					Matthew Dillon 

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]