DragonFly BSD
DragonFly kernel List (threaded) for 2005-05
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: libc changes and freebsd-4 compatible binaries

From: Joerg Sonnenberger <joerg@xxxxxxxxxxxxxxxxx>
Date: Mon, 2 May 2005 15:04:52 +0200
Mail-followup-to: kernel@crater.dragonflybsd.org

On Mon, May 02, 2005 at 11:30:32AM +0300, Yury Tarasievich wrote:
> The level of discussion is well beyond my competence, could somebody offer 
> clear explanation -- will freebsd-4 compatible binaries continue working on 
> current DFBSD? E.g., Opera is still building their packages for 2.95.4 and 
> libc.so.4 and there are lots of packages I'm using off-the-site and wouldn't 
> ever bother to recompile them. So, what about it? Thanks.

If you have installed your system _before_ the libc bump, nothing
changes for you [with the possible exception of locale support, e.g.
if you set LC_*]. For the rest we are currently discussion what to do.
The two basic options are:
(1) Provide a port / package analog to misc/compat4x (misc/compatdf12 ?).
For the mean time, it could be automatically installed with the LiveCD.
(2) Push them as binaries into src/lib/compat or so and install them
with the normal world.

I strongly prefer (1), Matt prefers (2). The argument for (2) is the
self-contained nature of the CVS repo, the argument for (1) is less
bloat and that the same mechanism is used by FreeBSD. Once you have
all your packages converted, you can do a simple pkg_delete and be done.

Matt, we could build some minimally changed libc with alternative path
to the locale files and package them as well. That would help against
the locale problem.


[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]