DragonFly BSD
DragonFly kernel List (threaded) for 2005-09
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: PKGSRC will be officially supported as of the next release

From: Peter Schuller <peter.schuller@xxxxxxxxxxxx>
Date: Sun, 4 Sep 2005 12:46:53 +0200

>     The problem with using languages like that is often that they require
>     significant infrastructure just to work.  It's a big problem for a 
>     package manager to have to have a dozen libraries and fifty megabytes
>     worth of packages installed before the package installer itself will
>     run.  We've encountered this issue just trying to make 'cvsup' and
>     perl-driven programs work on multiple occassions.

pkgmanager is currently written to work with 'clisp' because it is the
least "heavy" among the major CLs, in terms of compilation time / disk
space usage. clisp depends[1] on devel/readline, devel/pcre and
devel/libtool-base. I do not think that is all that bad. Especially
since almost any system with more than just a few packages will have
those packages anyway due to dependencies from other packages. They're
pretty basic.

That said, the biggest problem at the moment is portability. The
version of clisp in pkgsrc is not supported on amd64. I *think* amd64
is supported by newer versions of clisp, but since I do not have such
a machine yet I cannot test it and submit a patch to pkgsrc.

[1] pkgmanager itself also depends on a couple of CL libraries, but these
    are not very large and pretty quick to compile.

/ Peter Schuller, InfiDyne Technologies HB

PGP userID: 0xE9758B7D or 'Peter Schuller <peter.schuller@xxxxxxxxxxxx>'
Key retrieval: Send an E-Mail to getpgpkey@xxxxxxxxx
E-Mail: peter.schuller@xxxxxxxxxxxx Web: http://www.scode.org

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]