DragonFly BSD
DragonFly kernel List (threaded) for 2005-09
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: PKGSRC will be officially supported as of the next release

From: Nathan Hawkins <utsl@xxxxxxxx>
Date: Mon, 05 Sep 2005 10:00:05 -0500

Hash: SHA1

Yury Tarasievich wrote:
> On 3 September 2005 19:37, Matthew Dillon wrote:
>>    The problem with using languages like that is often that they require
>>    significant infrastructure just to work.  It's a big problem for a
>>    package manager to have to have a dozen libraries and fifty megabytes
>>    worth of packages installed before the package installer itself will
> ...
> I'd like to support Andreas here, on general assumption that 50 megs of 
> supporting packages is nothing if the tool (language) itself is appropriate 
> for the job and if the tools has a fairly wide support. Recognized, supported 
> and stable is what lisp seems like to me.
> AFAIK, there are some major linguistics and AI packages written in lisp.

Makes it difficult for embedded systems, not to mention people using
dialup. And a lot of people would be annoyed to have 50M of mandatory
packages that wouldn't otherwise be necessary.

It'd make a lot more sense to me to use Perl or Python if one were going
that route. At least those are languages that more pople know. Most
other interpreted languages would severely restrict the number of people
that could maintain the code. I've never seen anyone using Lisp outside
of school.

- --

		"If Tyranny and oppression come to this land, it will be
		in the guise of fighting a foreign enemy." James Madison
Version: GnuPG v1.4.1 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org


[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]