DragonFly BSD
DragonFly kernel List (threaded) for 2006-10
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: update of sound infrastructure

From: Petr Janda <elekktretterr@xxxxxxxxxxxxxx>
Date: Wed, 18 Oct 2006 23:34:07 +1000

I figured I must have forgot the -p0 so i patched again and get this instead.

. ./../dev/sound/pcm/channel.c:28:21: opt_isa.h: No such file or directory
mkdep: compile failed
*** Error code 1

Petr Janda wrote:
I get this while trying to compile it:

/usr/src/sys/compile/EVELIN/usr/src/sys/dev/sound/driver/ad1816 created for /usr/src/sys/dev/sound/driver/ad1816
===> dev/sound/driver/atiixp
cd: can't cd to /usr/src/sys/dev/sound/driver/atiixp


Simon 'corecode' Schubert wrote:

I tried updating our sound infrastructure to freebsd-6's one and I included the new HDA driver as well. Please test it, available at <http://chlamydia.fs.ei.tum.de/~corecode/unsorted/sound-update.diff> (cd /sys; patch -p0 < sound-update.diff). It would be nice if we could get it in for the next release.


1. modules don't load dependencies: you have to kldload sound.ko manually
2. xmms acts weird (plays fine, but the UI laggs 5-10 seconds)

please try an report back if it works or not.

note: you don't have to run buildworld, buildkernel is sufficient. actually rebuilding dev/sound modules is sufficient.


[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]