DragonFly BSD
DragonFly users List (threaded) for 2004-10
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: Looking at giving DF a go... advice?

From: "Mark Cullen" <mark.cullen@xxxxxxxxxxxxx>
Date: Sun, 10 Oct 2004 10:41:54 +0100

"Roland Hammerle" <romendo@xxxxxxxxx> wrote in message
> justin@xxxxxxxxxxxxxxxxxx wrote:
> > As far as ports go: in general, check gobsd.com/packages - some ports
> > have trouble building, but pkg_add -r will get you the versions from
> > gobsd.com that have already been successfully built.  Some of the
> > are a bit older - I'm using KDE 3.2, for instance, and I don't think
> > been updated on gobsd.com - but that doesn't hurt anything, really.
> > you don't have to wait ninety billion years for it to build.
> Since I installed from ports recently, i.e. yesterday, I would like to add
> my experiences here. KDE 3.3 (kdelibs, kdebase, kdenetworking,
> kdepim) all installed without major problems. There seem to be a few
> dependency problems because it complained about missing autoconf/automake.
> This was easily fixed by installing the corresponding port. I had to do a
> make clean in a few places (I think pkgconfig) and fix one Makefile (it
> not know about MASTERDIR). Also, install fam (from dfports) first because
> otherwise building it won't find some dependencies. Other than that
> everything works fine and I got a shiny, new KDE 3.3.
> -- Roland

Atleast I know it's possible to get KDE 3.3 installed, even if it is a bit
of an effort :-) KDE is probably the last thing on my list though, I may
even settle for 3.2.x as I was only really using Kate and Konqueror under

I managed to install x.org via a package, but it seemed like it may have
been a bit broken or something? At first it complained about no libXft,
which I solved by installing that package. Everything seemed to work ok, but
it took a few seconds after seeing the mouse cursor before it wanted to
move. I am now running XFree86-4.4.0 and all is well!

I tested for any mouse jerkyness quickly by running a find and it didn't
seem to jerk, while doing a buildworld too. Things are looking good! Swap
usage also *appears* to be better, I have used 4k doing a buildworld,
running X and IceWM. I'll have to wait and see what happens with a setup
similar to what I was running on FreeBSD though I guess. I'm getting
impatient now!

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]