DragonFly BSD
DragonFly users List (threaded) for 2004-10
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: weird link problem with the postfix install?

To: Matthew Dillon <dillon@xxxxxxxxxxxxxxxxxxxx>
From: Mark Cullen <mark.cullen@xxxxxxxxxxxxx>
Date: Fri, 22 Oct 2004 23:23:30 +0100

Matthew Dillon wrote:
:Hi there
:I'm making some progress, I have samba, php, mysql and apache installed :on my new DragonFly box alright, from ports may I add. It's nearly at a :state where I might be able to test run it soon.
:I have a small problem with Postfix though (2.1.x). When I try and do a :make install it spits back an error at me:
:mv: chown: /usr/local/bin/newaliases: Bad file descriptor
:mv: chflags: /usr/local/bin/newaliases: Function not implemented
:mv: /bin/cp: terminated with 1 (non-zero) status: Cross-device link

    These are bugs in the VFS compatibility code in HEAD.  If you just
    want to get something working, these bugs should not exist in the
    DragonFly_Stable tag.

    I am able to reproduce the problem so I should be able to fix this
    today if you want to wait and continue to use HEAD (the head of the cvs


Woah, as far as I am aware I am using Stable. My brain's not been so good the past few days mind, as you know.

*default release=cvs tag=DragonFly_Stable

uname does say 1.1-CURRENT still though...

As it goes though, I ran make install again and it got past newaliases and did the same thing on the next file in the list. Ran it again and it seems to have installed. It seems to be working alright, it managed to send a mail off to my email account anyway *shrugs*

Internet Explorer? Try FireFox at http://www.mozilla.org/products/firefox/
Outlook Express? Try ThunderBird at http://www.mozilla.org/products/thunderbird/

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]