DragonFly BSD
DragonFly users List (threaded) for 2004-10
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: checking for bad media

From: "George Georgalis" <george@xxxxxxxxx>
Date: Sun, 31 Oct 2004 14:50:10 -0500

On Sat, Oct 30, 2004 at 11:52:06PM -0700, Matthew Dillon wrote:
>:>    Maybe it's the hard disk you are installing to that is having the 
>:>    media problems instead of the CD.  That's the only thing I can think
>:>    of that would result in an error at the same place every time.  Usually
>:>    IDE driver problems, bad cables, and bad CD drives error out in a
>:>    different location each time.
>:The errors are with the cd device reads. I'm kinda stuck as far as
>:capturing the output, the installer won't work via ssh (with su or ssh
>:-l installer), stops near beginning, during setup. And I had bought
>:null modem cables to try a serial install, but all the forknibbler docs
>:(which I need) are unavailable atm, even by google cache...
>    Hmm.  Very odd.  If you have another CD drive (of a different brand)
>    that you can throw in there it might be worth trying that.  You can
>    also try forcing the driver to talk to the CD more slowly using
>    atacontrol.  e.g. login as root on the CD and do:
>    [ list current ATA modes ]
>    atacontrol mode 0
>    atacontrol mode 1
>    If the CD is on channel 1 and has negotiated PIO4 you could try forcing
>    it to operate more slowly with something like :
>    atacontrol mode 1 PIO3 -
>    Then login again as the installer and see if it gets further.

Well, can't do that. here's a series of events in reverse order.

I put the cdrom in a fresh (completed) install, mounted it and was able
to successfully get md5 from csh and tcsh

MD5 (/cdrom/bin/csh) = e6a885a0d2444eeaeb180b8ac40305c5
MD5 (/cdrom/bin/tcsh) = e6a885a0d2444eeaeb180b8ac40305c5

on the via epia cl10000 box, the cd boots and installer seem to work fine,
until cpdup errors with (approx, hand copied)

(cd0:ata1:0:0:0):CDB: 28 0 0 0 17 b2 0 0 10
(cd0:ata1:0:0:0):Medium Error asc:11,0
(cd0:ata1:0:0:0):cddone: got error 0x5 back
(cd0:ata1:0:0:0):Medium Error asc:2,0
(cd0:ata1:0:0:0):No Seek Complete
(cd0:ata1:0:0:0):cddone: got error 0x5 back

says /mnt/bin/csh error and copies a few other files and generates the
same block of errors and says /mnt/bin/tcsh error, does a few more
files and exits 1.

There is only one 40G disk on the primary ide. The cdrom is connected to
the secondary ide channel and I've tried several permutations of a known
good cdrom drive as slave, master, cable select.  All with same results.

This box won't let me log in as root, presumably because it cannot open
the shell... when I tried booting the cdrom headless with null modem
cable and "cu -l /dev/cuaa0" from a dfly install, I got lots of garbage
when the cd began booting, maybe because baud rates are different, not
sure why they would be or how to fix...

It looks like a media problem but the media reads fine on another box,
and two (new) cdrom drives give the exact problem.  I'm going to try
installing something else on it and see what happens...

// George

George Georgalis, systems architect, administrator Linux BSD IXOYE
http://galis.org/george/ cell:646-331-2027 mailto:george@xxxxxxxxx

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]