DragonFly BSD
DragonFly users List (threaded) for 2005-01
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: linuxpluginwrapper, how to install?

From: Guillermo Garcia Rojas <garciarojas@xxxxxxxxxxx>
Date: Mon, 03 Jan 2005 16:31:39 -0600

It didn't work for me. 
When doing patch -p0 ... it says something like its going backwards 
on the code, like downgrading and then, port breaks on linux_socket or
something like that.

On Mon, 20 Dec 2004 00:07:53 +0900, YONETANI Tomokazu wrote:

> Hi.
> On Sun, Dec 19, 2004 at 03:22:37PM +0000, Lukasz Byczynski wrote:
>> i have problems when installing this port.
>> 4-stable user:
>> 	You can get a following patch.
>> 	http://people.FreeBSD.org/~nork/libmap_4stable.diff
>>    Please apply on /usr/src and make install on /usr/src/libexec/rtld-elf:
>>    # cd /usr/src ; patch -p0 < /tmp/libmap_4stable.diff
>>    # cd libexec/rtld-elf ; make clean all install
>> 5.1-RELEASE user:
>> 	Please see /usr/src/libexec/rtld-elf/Makefile.
>> *** Error code 1
>> Stop in /usr/ports/www/linuxpluginwrapper.
> If you don't mind messing with rtld-elf and installing libmap, please
> follow the instruction for 4-stable user. I was using it last year, but
> I'm not sure if the patch(or the patched binary) still works.
> A simple LD_LIBRARY_PATH seems to work most of time for me. Here's a
> WORKAROUND I'm using:
> 1. edit the Makefile to ignore the message:
> # cd /usr/ports/www/linuxpluginwrapper
> # sed -i.bak '/FALSE/d' Makefile

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]