DragonFly BSD
DragonFly users List (threaded) for 2005-01
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Problems booting an SMP kernel

From: "Douglas S. Keester" <dkeester@xxxxxxxxxxxxx>
Date: Mon, 24 Jan 2005 18:15:26 -0700


	I am trying to run an SMP kernel on my dual processor Pentium 3. The kernel 
builds correctly with SMP and APIC_IO uncommented, however it will not boot 
properly. The kernel loads and is able to detect all of my hardware but it 
halts where the GENERIC kernel would be trying to mount /. Here are the last 
messages that I am seeing:

APIC_IO: Testing 8254 interupt delivery
APIC_IO: routing 8254 via IOAPIC #0 intpin 2
SMP: AP CPU #1 Launched!
ad0: 78167MB <Maxtor 98196H8> [158816/16/63] at ata0-master UDMA66
acd0: CD-RW <Memorex 52MAXX 3252AJ> at ata1-master PIO4
afd0: 239MB <IOMEGA ZIP 250 ATAPI> [239/64/32] at ata1-slave PIO3
<kernel halts here>

	The GENERIC kernel usually halts here for a few seconds, so I have tried 
letting it sit for several minutes. The system never continues beyond that 
point, however.

	When I ctrl+alt+esc out to DDB and try to use the 's' or 'n' commands I get 
messages about CPU #0 stopping and restarting.

	My system has the following specs.
	-dual P3 800
	-MSI 649D ProA board
		-VIA 694XDP northbridge (133MHz FSB)
		-VIA VT82C686A southbridge (UDMA33/66)
		-On board AC97 audio
		-On board Promise ATA 100 RAID (currently unused)
	-650 MB PC133 RAM
	-82 GB Maxtor hdd

	I have tried setting the ROOTDEVNAME option in my kernel config, which did 
not work.

	Any hints or help would be much appreciated. Thanks.

Douglas S. Keester

[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]